Archivo de la categoría: Electronic Signature

Estándares de firma electrónica


Aunque ya he tratado estos temas en algunos artículos anteriores, he pensado que merece la pena tener en un solo lugar una lista de los estándares de uso frecuente en relación con la firma electrónica.

  • CAdES (CMS Advanced Electronic Signatures). ETSI TS 101 733 CAdES version 1.7.4 from Jul, 2008
  • XAdES (XML Advanced Electronic Signatures). ETSI TS 101 903 XAdES version 1.4.1 from 2009-06-15
  • PAdES (PDF Advanced Electronic Signatures). ETSI TS 102778  (PAdES FAQ) Noticia
  • RFC 2560 «Online Certificate Status Protocol – OCSP»
  • RFC 3126 “Electronic Signature Formats for long term electronic signatures”
  • RFC 2630 «Cryptographic Message Syntax»
  • RFC 2634 «Enhanced Security Services for S/MIME»
  • RFC 5126 “CMS Advanced Electronic Signatures (CAdES)”
  • RFC 3280 «Certificate and Certificate Revocation List (CRL) Profile»
  • RFC 3275  «(Extensible Markup Language) XML-Signature Syntax and Processing «
  • RFC 2797  «Certificate Management Messages over CMS»
  • RFC 2585  «Operational Protocols: FTP and HTTP»
  • RFC 3161  «Time-Stamp Protocol (TSP)»
  • RFC 3029 «Data Validation and Certification Server Protocols»
  • RFC 3852  «Cryptographic Message Syntax» (deja obsoletos los RFC3369, RFC 3211, RFC 2630, RFC 2315-PKCS #7 version 1.5-)
  • RFC 4853 – (Actualización Marzo 2008) «Cryptographic Message Syntax – Multiple Signer Clarification»
  • CWA 15579  E-invoices and digital signatures
  • ETSI TS 102 042 Policy requirements for CA issuing PKC
  • ETSI TS 102 023 Policy Requirements for Time Stamping Authorities Certificates for Electronic Signatures – Part 1: System Security Requirements
  • ETSI TS 102 231 Provision of harmonized Trust Service Provider status information (TSL)
  • ETSI TS 102 280 X.509 V.3 Certificate Profile for Certificates Issued to Natural Persons
  • ETSI TS 102 158 Policy requirements for Certification Service Providers issuing attribute certificates usable with Qualified certificates
  • ETSI TS 101 861 V1.2.1  Time stamping profile
  • CEN / ISSS CWA 14167-2 Cryptographic module for CSP signing operations with backup – Protection profile – CMCSOB PP
  • CEN / ISSS CWA 14167-3 Cryptographic module for CSP key generation services protection profile CMCKG-PP
  • CEN / ISSS CWA 14167-4 Cryptographic module for CSP signing operations – Protection profile – CMCSO PP
  • CEN / ISSS CWA 14169 Secure signature-creation devices «EAL 4+»
  • CEN / ISSS CWA 14170 Security requirements for signature creation applications
  • CEN / ISSS CWA 14171 General Guidelines for Electronic Signature Verification
  • CEN / ISSS CWA 14172 EESSI Conformity Assessment Guidance (8 parts)
  • CEN / ISSS CWA 14355 Guidelines for the implementation of Secure Signature-Creation Devices
  • CEN / ISSS CWA 14365-1 Guide on the Use of Electronic Signatures – Part 1: Legal and Technical Aspects
  • CEN / ISSS CWA 14365-2 Guide on the Use of Electronic Signatures – Part 2: Protection Profile for Software Signature Creation Devices
  • CEN / ISSS CWA 14167-1 Security Requirements for Trustworthy Systems Managing
  • CEN / ISSS CWA 14890-1 Application Interface for smart cards used as Secure Signature Creation Devices – Part 1: Basic requirements
  • CEN / ISSS CWA 14890-2 Application Interface for smart cards used as Secure Signature Creation Devices – Part 2: Additional Services
  • TR 102 047 (International Harmonization of Electronic Signature Formats)
  • FIPS PUB 180-1 (Secure Hash Standard)
  • ISO 32000

Artículos anteriores:

La UFV crea el GINTA, Grupo de investigación dedicado a las AA.PP.


La Universidad Francisco de Vitoria (UFV) crea «GINTA» Grupo de Investigación sobre Nuevas Tecnologías Aplicadas.

El Grupo GINTA está formado por Profesores de la Universidad y Profesionales del mundo Empresarial relacionados con las Nuevas Tecnologías

Ante la necesidad de aplicar intensivamente la tecnología en las administraciones públicas y otros sectores, se ha creado un grupo especializado en el conocimiento de las necesidades de estos, tanto a nivel tecnológico como jurídico y económico para ofrecer soluciones integrales.

El objetivo del grupo se centra en dos líneas: Administraciones Públicas Locales para su Gestión Interna y Entidades Financieras en su desarrollo de Business Inteligence (B.I.).

Para ello, el grupo preparará y entregará Proyectos de Innovación Tecnológica y Business Intelligence (Inteligencia de Negocio) relevantes, que sean del interés de las Administraciones Públicas: Ayuntamientos y Empresas Multisectoriales: Sector Financiero, Banca, Seguros, Sector de las Telecomunicaciones, Tecnologías de la Información y de la Comunicación, Energía, Bienes de Consumo etc… y también se presentará a Concursos y Licitaciones de proyectos de Innovación Tecnológica Aplicada en el mundo de las Administraciones Publicas, así como a convocatorias externas de ayudas específicas sujetas a los planes nacionales y regionales de fomento de ciencia y tecnología, contando para ello con el apoyo de la OTRI (Oficina de Transferencia de Resultados de Investigación) de la UFV.

En el ámbito de las Administraciones locales colaborará en el diseño, elaboracion e imparticion de cursos y seminarios organizados por la Administración a los colectivos sectoriales que estos determinen.

Equipo

El grupo bajo la dirección de Ignacio Temiño Aguirre está compuesto por Inmaculada Puebla Sánchez, Mara Sánchez Benito, Rodrigo Navalón García, Delia Nogales Uzabal, Natalia Cobos Lanáquera, Manuel Robredo Botella, así como por Julián Inza Aldaz y Miguel Ángel de Bas Sotelo.

El Grupo de Investigación GINTA ha identificado mediante reuniones con autoridades locales y empresas sectoriales necesidades en los campos en los que centrará su investigación:

  • Administraciones Públicas Locales para su Gestión Interna:
    • Incrementar su apertura Digital (Documentación, Expedientes Contratación Electrónica);
    • Registro Telemático;
    • Gestión Documental;
    • Plataforma de Licitación Telemática;
    • Virtualización,
    • Ordenación CPD;
    • Documentos electrónicos;
    • Sede electrónica;
    • Notificaciones fehacientes;
    • Publicación fehaciente en el perfil del contratante;
    • Custodia Digital;
    • Códigos Seguros de Verificación;
    • Certificación de Seguridad del organismo;
    • Certificados de sede electrónica, de sello electrónico y de empleado público;
    • Compulsa electrónica;
    • Pago telemático;
    • Interoperabilidad;
    • Dirección Electrónica Única;
    • Verificación de Datos de Identidad y Residencia;
    • Supresión de certificados en soporte papel;
    • Comunicación de Cambio de Domicilio;
    • Digitalización Certificada
  • Entidades Financieras en su desarrollo de Business Intelligence (B.I.):
    • Redes Avanzadas en B.I. y Tecnologías de la Información IT ;
    • Banca Virtual; Certificado Digital;
    • Factura Electrónica;
    • Firma Electrónica;
    • Marketing Social: ERP, CRM, Datamining, Datawarehouse ….;
    • Redes Sociales y Audiovisuales;
    • Diseño Gráfico de Interfaces y Usabilidad;
    • Herramientas Colaborativas, canal Web;
    • Plataformas orientadas a servicios (SOA);
    • Plan de seguridad y de sistemas;
    • Redes avanzadas en Movilidad; ……

Y todo ello con una especial aplicación de las normativas vigentes en los proyectos objetivo.

Referencia: Club de la Innovación

Información sobre los grupos de investigación de la Universidad Francisco de Vitoria

Practitioners call for immediate adoption of better eInvoicing rules


Varios especialistas en factura electrónica de toda Europa hemos estado reflexionando estos últimos meses sobre algunas de las conclusiones recogidas en el Informe Final del Grupo de Expertos en Factura Electrónica de la Comisión Europea con las que no estamos de acuerdo y con las que se está presionando a los representantes de los paises miembros que están negociando bajo la Presidencia Española la nueva redacción de la modificación de la Directiva 112/2006.

Hemos preparado un texto que nos gustaría difundir y hacer llegar a los negociadores del futuro texto de la directiva.

Practitioners call for immediate adoption of better eInvoicing rules under the Spanish Presidence

Albalia es Advanced Partner de IBM


Estamos muy contentos en Albalia Interactiva. Aunque ya llevamos más de dos años colaborando con IBM en diversos proyectos, en estos momentos acabamos de recibir la confirmación de nuestra Certificación como Advanced Partner y la de nuestro producto zBackTrust que ya está oficialmente certificado para ser utilizado en los Mainframe System z, como por ejemplo en los z10.

También es un orgullo que INSA sea la entidad distribuidora de la Solución, que resuelve los principales retos que imponen para su cumplimiento las leyes 11/2007 para el sector público o la 56/2007 para el sector privado (Interlocución telemática).

Y también estamos muy agradecidos a Caixa Galicia que ha sido la primera entidad en implantar zBackTrust y que ya es un usuario satisfecho que nos ha ofrecido la posibilidad de mostrar nuestra solución en sus instalaciones de La Coruña a los potenciales clientes.

Con la creciente importancia de la firma electrónica y del DNI electrónico en todos los sistemas de las administraciones públicas y de entidades privadas, como bancos, aseguradores y telecos, la posibilidad de gestionarlas en el Host abre enormes posibilidades de gestión y representa un pilar en el despliegue de sistemas que den cobertura al nuevo paradigma de la gestión documental electrónica con carácter probatorio.

Otros artículos relacionados:

VIII Jornadas Ceres


A partir de mañana se celebran las VIII Jornadas Ceres, que tienen lugar el 10 y 11 de Marzo de 2010, en Madrid, en el Museo de la FNMT-RCM, Doctor Esquerdo, 36.

Uno de los eventos imprescindibles en el mundo de la firma electrónica, con especial énfasis, este año, en la puesta en marcha de la Administración Electrónica: “Ley 11/2007: una realidad en 2010”

Este es el Programa previsto:

10 de Marzo de 2010

9:00 – 10:00 Recepción de asistentes y entrega de documentación
10:00 – 10:20 Apertura de las Jornadas
D. Ángel Esteban Paúl
Presidente – Director General de la FNMT-RCM
D. Manuel Núñez Pérez
Presidente del Tribunal de Cuentas

Panel 1. – Moderador: D. Fernando Martín (Jefe de la Unidad de Apoyo Informático – Tribunal de Cuentas)

10:20 – 10:40 «Los Ciudadanos y la Ley 11/2007»
D. Fernando de Pablo Martín
Director General para el Impulso de la Administración Electrónica.
Ministerio de la Presidencia

10:40 – 11:00 “Entorno normativo tras la efectividad del derecho a la Administración Pública”
D. Maximino Linares
Director del Servicio Jurídico de la AEAT

11:00- 11:20 “Servicios de Administración electrónica confiables para ciudadanos y empresas”
D. Víctor Izquierdo Loyola
Director General INTECO

11:20 -11:50 Café y visita a la exposición

Panel 2. – Moderador: Dª. Susana García Dacal (Coordinadora de la Dirección General de Innovación y Modernización Administrativa – Junta de Castilla y León)

11:50 – 12:10 “Evolución de los servicios de firma y factura electrónica”
D. Miguel Ángel Corpa Ortiz
Senior Manager responsable de servicios de firma electrónica
Accenture

12:10 – 12:30 «La iniciativa de la Junta de Andalucía»
D. Manuel Perera Domínguez
Jefe de Servicio de Coordinación de Administración Electrónica
Consejería de Justicia y Administración Pública
Junta de Andalucía

12:30 – 12:50 “Grado de cumplimiento Ley 11/2007”
Dª María América Álvarez
Directora General de Informática
Principado de Asturias

12:50 – 13:10 “Una plataforma al servicio de la Ley 11/2007”
D. Ramón Lucini
Key Account Manager Spain & Portugal
THALES Information Systems Security

13:10 – 13:30 “Administración electrónica en la Comunidad Autónoma de la Región de Murcia”
D. Manuel Escudero Sánchez
Director General de Informática y Comunicaciones
Comunidad Autónoma de la Región de Murcia

13:30 – 13:50 “Extensión de la Administración Electrónica al puesto de usuario del Gobierno de Cantabria”
D. Santiago García Blanco
Director General de Desarrollo e Innovación Tecnológica
Gobierno de Cantabria

13:50 – 16:20 Almuerzo

Panel 3. – Moderador: Dª Virginia Moreno (Directora de Informática – Ayuntamiento de Leganés)

16:20- 16:40 «La administración electrónica en el Ayuntamiento de Madrid: Situación actual y propuestas de futuro»
Dª Luisa Ana Blanco Losada
Subdirectora General de Administración Electrónica
Ayuntamiento de Madrid

16:40 – 17:00 “La experiencia de Sun con la FNMT ”
D. José Ángel Cortijo López
Director Comercial del sector Público
Sun

17:00 – 17:20 “Administración-e en la Red Provincial de Almería”
D. Luis García Maldonado
Jefe de Régimen interior y Administración local
Diputación de Almería

17:20 – 17:40 “Región Digital Madrid Noroeste: Tu Ayuntamiento en casa”
Dª Cristina Durán Uribarri
Concejal de Tecnologías
Ayuntamiento de Majadahonda

17:40- 18:40 Vino español

11 de Marzo de 2010

9:15 – 10:00 Recepción de asistentes y entrega de documentación

Panel 4. – Moderador: D. Francisco Antón Viqué (Subdirector General – Ministerio de Educación)

10:00 – 10:20 “Experiencia de la puesta en funcionamiento de las sedes electrónicas del Ministerio de Economía y Hacienda.”
Dª María José de Mariano Sánchez-Jáuregui
Jefa Unidad de Gestión de Contenidos en la Red
Ministerio de Economía y Hacienda

10:20 – 10:40 “Garantías de disponibilidad en las infraestructuras de T.I.”
D. Josep Verdura
Director Marketing
IPM

10:40– 11:00 «Evolución de la Administración Electrónica»
D. Francisco Gijón Romero
Subdirector General de Tecnologías y Sistemas de la Información Ministerio de Fomento

11:00 – 11:30 Café y visita a la exposición

Panel 5. – Moderador: Dª María del Mar España (Secretaria General del Defensor del Pueblo)

11:30 – 11:50 “Servicios Informáticos de la AEAT. Escala de cambios y cambios de escala”
D. Ignacio González García
Director General de Informática Tributaria
AEAT

11:50 – 12:10 «Servicios de Seguridad, firma electrónica e identificación en la Nube»
D. Juan Miguel Velasco López-Urda
Gerente de Ingeniería de Seguridad. Grandes Clientes
Telefónica

12:10 – 12:30 “La aplicación de la Ley 11/2007 en el Ministerio de Economía y Hacienda”
D. José Aurelio García Martín
Inspector de los Servicios
Ministerio de Economía y Hacienda

12:30 – 12:50 «Ley 11/2007: Camino recorrido e hitos pendientes»
D. Juan Carlos De Miguel Pérez-Herce
Gerente de Desarrollo de Negocio – Sistemas de Seguridad
Indra

12:50 – 13:10 “La `supervivencia’ en entornos hostiles. El nuevo paradigma de la seguridad de los servicios públicos prestados a través de medios electrónicos”
D. Jaime Denis Zambrano
Director General INTA

13:10 – 13:20
D. Luis Roldán Alegre
Director General de Tecnologías
Gobierno de Aragón

13:20 – 13:50 Clausura de las Jornadas
Dª Consuelo Rumí Ibáñez
Secretaria de Estado de Función Pública
D. Ángel Esteban Paúl
Presidente Director General de la FNMT-RCM

Productos y servicios basados en DSS


En el artículo «Firma electrónica con OASIS DSS» ya di algunas indicaciones de la importancia de este protocolo para desplegar servicios de firma electrónica en las grandes organizaciones. Recientemente se ha anunciado que está previsto incluir esta funcionalidad en futuras versiones de @firma, la herramienta más utilizada en las administraciones públicas para gestionar firmas electrónicas.

En el momento actual, solo dos productos dan soporte a este protocolo:

Sin embargo, sí que está disponible como servicio (en lo que en Albalia llamamos Trustworthiness of services in the cloud) a través de algunos prestadores de servicios de certificación:

En cuanto a entidades, Caixa Galicia lo ha implantado en su arquitectura sobre zSeries (Mainframe IBM), gracias a zBackTrust, la variante de BackTrust orientada a zLinux y z/OS, con Websphere.

Electronic Invoice Summit – Madrid – The 27, 28 and 29 of April 2010


In the framework of events of the  Spanish Presidency of the Council of the European Union, will take place in Madrid the Conference on “Electronic invoicing in Europe” organised by the European Commission. This international Conference will gather european eInvoice experts in the Auditorium of the State Secretariat of Telecommunications and the Information Society in Madrid the 27 and 28 of April 2010. ASIMELEC Congress on electronic invoice (this year in its 5th edition) will take place on the following day, the 29th of April of 2010, so delegates can particiate on both events if they wish to.

Aim of the conference

Electronic invoices, compared to paper invoices, offer substantial advantages for public and private organisations of all sizes. Widespread uptake of electronic invoicing could be of considerable benefit for the EU economy with potential savings for trading partners (senders and receivers of invoices). However, most of the potential offered by e-Invoicing remains untapped, especially among SMEs, because of the continued existence of regulatory and technical barriers to its full deployment.

Over the past few years, the European Commission has given continuous support to the uptake of e-Invoicing solutions. Several initiatives at European level have been launched in order to facilitate the emergence of a pan-European e-invoicing environment for businesses and public authorities. In particular, the Commission set up an independent Expert Group on e-Invoicing who proposed, at the end of 2009, a European e-Invoicing Framework (EEIF) with recommendations for the provision of e-Invoicing services in an open, competitive and interoperable manner across Europe.

In parallel to these initiatives, other activities affecting the uptake of electronic invoices are:

  • The creation of the Single Euro Payments Area (SEPA) and
  • The VAT directive (2006/112/EC) and its proposed amendments on electronic invoicing currently discussed at the Council.

The European e-Invoicing framework proposed by the Expert Group challenged the identified regulatory and technical barriers with recommendations addressing standards, interoperability, legal requirements and the uptake of e-invoicing by SMEs. These propositions have been published and are open to public consultation until the 26 February 2010.

The conference is being held at an appropriate moment to debate the recommendations of the Expert Group and discuss the key actions to be taken to remove the barriers which currently affect the use of electronic invoices. In that respect, four sessions addressing the current difficulties of e-Invoicing are planned on :

  • SMEs and E-invoicing
  • Interoperability
  • Standards
  • Legal framework for electronic invoices

Speakers will include Members of the European Parliament and the European Commission, representatives from the European Central Bank, high-level representatives of EU Member State governments, businesses, standardisation bodies and NGOs.

The conference is organised by the European Commission under the auspices of the Spanish Presidency of the Council. The conference will take place at the State Secretariat of Telecommunications and the Information Society in Madrid the 27 and 28 of April 2010.

This is a clear oportunity to learn more about UBL, the preferred XML format to be used internationally to foster electronic invoice interoperability.

ASIMELEC eInvoice Congress

ASIMELEC has been organizing  4 Congreses on Electronic Signature and Certified Imaging, and 2010 will see the 5th edition.   This year the event will show an international agenda with key bullets, such as interoperability issues, the ammendment of the VAT directive and fostering eInvoice adoption by SMBs. The date for the event is the 29 of april 2010, and will be organized in close relationship with the Official event.

One of the succes case will be based on the  Invoicex Project.

This V Congreso de Factura Electrónica y Digitalización Certificada, (5th Congress on Electronic Invoice and Certified Imaging) will have an approximate cost of 250 euros. In a few days, registration will be available at  ASIMELEC web site.

Related articles:

Discrepancia con el Informe del Grupo de Expertos


Recientemente he hecho referencia al Informe final del Grupo de Expertos en Factura Electrónica enfatizando algunas discrepancias que he detectado entre lo que es opinión mayoritaria en España (y en algunos paises europeos) y lo que refleja el propio Final Report of the Expert Group on e-Invoicing .

Hoy he tenido ocasón de comentarlo en Radio Líder, emisora que se escucha en toda Galicia.

Este es el trozo del programa «Entre nosotros» que dirige la periodista Ana Valiño, y que se ha interesado por este tema:

Los puntos claves son el «equal treatment«, la firma electrónica y el formato de la factura, que debería ser UBL ya que CII (el formato identificado por el Grupo de Expertos), como ya he comentado en otra ocasión, no está todavía listo.

Arquitectura normalizada de recepción de facturas electrónicas en la Administración General del Estado


El entorno de normalización de la factura electrónica en España parte de la Orden PRE/2971/2007 que definía el formato facturae y en cuya disposición final segunda se establecía su evolución en el plazo de dos años (que ya se han cumplido) al estándard UBL 2.0

Aunque aun no se ha publicado ninguna versión de facturae basada en UBL, sí que se han publicado otras versiones que resuelven algunos problemas detectados (y crean otros, ya que las versiones no son compatibles). Además de acoger extensiones sectoriales.

Con la publicación en el marco del Centro de Transferencia de Tecnología (CTT) de la arquitectura normalizada de recepción de facturas electrónicas en la Administración General del Estado se da un paso más en la disponibilidad de especificaciones técnicas para llevar a cabo la facturación electrónica al sector público.

La Comisión Permanente del Consejo Superior de Administración Electrónica (CSAE), en su reunión de 25 de marzo de 2009, acordó, a propuesta del Ministerio de Economía y Hacienda, la constitución de un grupo de trabajo sobre la arquitectura general de facturación electrónica en la Administración General del Estado. Este grupo surge dada la urgente necesidad de diseñar una arquitectura general de recepción de facturas electrónicas en el ámbito de la AGE para evitar la dispersión de esfuerzos y facilitar la implantación de la facturación electrónica. La coordinación de dicho grupo es encargada al propio Ministerio de Economía y Hacienda.

El objeto y alcance del grupo de trabajo se ha centrado en el análisis y elaboración de una propuesta de arquitectura general para la recepción de facturas electrónicas en la Administración General del Estado y organismos autónomos, y en la definición de las interfaces de las plataformas de facturación con los servicios de facturación de los proveedores, por un lado, con los sistemas de gestión económico-presupuestaria, por otro, y con los sistemas de registro electrónico, por último.

El Coordinador del grupo ha sido D. José María Sobrino, de la Intervención General de la Administración del Estado (IGAE) del Ministerio de Economía y Hacienda.

En el grupo de trabajo han participado representantes de 9 Ministerios (MPRE-Ministerio de la Presidencia, MEH-Ministerio de Economía y Hacienda, Ministerio de Justicia, Ministerio de Defensa, Ministerio del Interior, Ministerio de Fomento, MTIN-Ministerio de Tecnología e Innovación, MITyC-Ministerio de Industria, Turismo y Comercio y Ministerio de Cultura ) y de 7 entidades públicas (AEAT, INE, FNMT, Comisión Nacional de la Competencia, RED.es, Correos, Seguridad Social), con una media de asistencia a las reuniones de 23 personas.

Las conclusiones del grupo de trabajo y sus documentos se finalizaron el 25 de noviembre de 2009.

Objetivos

El objeto y alcance del grupo de trabajo se ha circunscrito a la arquitectura general para la facturación electrónica en la Administración General del Estado y organismos autónomos, siendo sus principales objetivos:

  1. Analisis de la conveniencia de plantear un punto general de entrada y distribución de facturas electrónicas (PGEFe) y, si se adopta la decisión de su conveniencia, establecer:
    • Las funciones del PGEFe.
    • Las necesidades adicionales para el enrutamiento automático de la factura
  2. Análisis de la posibilidad adicional de que el PGEFe pueda desempeñar la función de plataforma de emisión y recepción de facturas electrónicas para aquellos departamentos, centros gestores u organismos que optaran por no disponer de su propia plataforma.
  3. Normalización de las interfaces entre los sistemas de facturación de los proveedores y las plataformas de facturación electrónica de las entidades públicas (y, en su caso, el PGE-Fe).
  4. Normalización de las interfaces entre las plataformas de facturación electrónica (y, en su caso, el PGEFe) y los sistemas de registro electrónico de los departamentos.
  5. Normalización de las interfaces de comunicación entre las plataformas de facturación electrónica y los sistemas de gestión.

Ventajas

  • Se establecen unas interfaces puestas a disposición de los proveedores de plataformas de facturación y de sistemas de gestión económico- presupuestaria de modo que se facilita la implementación y gestión de la facturación electrónica.
  • Se apuesta por la creación de un punto general de entrada y distribución de facturas electrónicas (PGEFe).
  • El PGEFe puede actuar como punto general de entrada y distribución, y plataforma de emisión y recepción de facturas electrónicas para aquellos departamentos, centros gestores u organismos que optaran por no disponer de su propia plataforma.

Detalles técnicos

Estos son los Escenarios de la arquitectura e interfaces de facturación electrónica en la AGE

Escenario I: El organismo receptor de facturas dispone de su propia plataforma de recepción de facturas electrónicas y solicita al proveedor que le envíe directamente las facturas a dicha plataforma.

Escenario II: El organismo receptor de facturas dispone de su propia plataforma de recepción de facturas electrónicas, pero la recepción y consulta de estado de las facturas se realiza a través del punto único PGEFe.

Escenario III: El organismo receptor de facturas no dispone de su propia plataforma de recepción de facturas electrónicas. En este caso, se utiliza la Plataforma Central de Facturación AGE.

Restricciones para la recepción de facturas electrónicas en la AGE

  • Formato de recepción de facturas: Actualmente Facturae, en cualquiera de sus versiones publicadas (3.0, 3.1 y 3.2 en la actualidad).
  • Implícitamente, se limita también el formato de firma electrónica admitida según definición de Facturae:
    • Estándar XAdES (EPES o XL).
    • Política de firma Facturae (2 versiones publicadas hasta el momento: 3.0 y 3.1).
  • Los accesos a la plataforma de recepción de facturas AGE son siempre securizados (acceso vía certificado electrónico o usuario y contraseña).
  • No se admiten facturas por lotes ni envíos de arrays de facturas.

Interfaces

Interfaz proveedor con plataformas o PGEFe.

Dos mecanismos: Automático (servicios web alojados en las plataformas) o Manual (formularios web).

  • Recepción de facturas.
  • Consulta de facturas (por identificador de factura o por apunte registral).
  • Anulación de facturas.

Interfaz plataformas o PGEFe con Sistemas de Gestión.

Vía automática (servicios web alojados en los sistemas de gestión)

  • Alta de factura.
  • Consulta de estado de facturas.
  • Anulación de facturas.

Vía no automática (servicios web alojados en la plataforma de facturación).

  • Solicitud de relación de nuevas facturas.
  • Descarga de facturas.
  • Cambio de estado de facturas.

Vía manual (ver facturas disponibles; descarga de fichero facturae y actualización de estado de factura).

Asignación de código electrónico en la plataforma de facturación.

Interfaz plataformas o PGEFe con Registro órgano gestor o Registro Electrónico Común.

  • Registro.
  • Consulta de apuntes.

Informe final del Grupo de Expertos en Factura Electrónica


El Final Report of the Expert Group on e-Invoicing es el resultado de más de un año de trabajo de más de 30 expertos de toda Europa.

Junto con conclusiones que verdaderamente pueden ser de consenso se incluyen otras que parecen sesgadas por determinados intereses políticos, y en defensa de algunas posiciones particulares.

El informe tiene partidarios y detractores como puede verse en estos blogs:

Las dos posiciones son relevantes porque de la tesis «triunfadora» depende el consenso para la modificación de la Directiva 2006/112/EC, cuyo borrador actual está disponible.

La posición mayoritaria en España es que no es conveniente cambiar las reglas del juego a mitad del partido, y que tampoco es aceptable, ni siquiera dar a entender que se pueden cambiar. El efecto que tendría es que todos los jugadores se pararan hasta que queden claras las reglas de nuevo, ralentizando la expansión de la factura electrónica. Otra posición mayoritaria en España es que tampoco se deben cambiar las reglas de forma que favorezcan a los más lentos (o a los más torpes) del mercado pero con gran potencia de lobby como algunas entidades financieras europeas (afortunadamente, no las españolas).

Entre todos los conceptos que se manejan, el más peligroso es el de «equal treatment» refiriéndose a un tratamiento igual de las facturas electrónicas respecto a las de papel. Y sin definir qué significa eso.

Para ser correcto, debería llevar la coletilla latina «mutatis mutandi», que significa que se aplica la semejanza cambiando lo que haya que cambiar, como consecuencia de la diferencia de soporte que conlleva formas diferentes de gestionar. Por ejemplo, en una factura en papel se le puede poner el sello «pagado» sobre el documento original. Eso no es tan fácil de representar en un documento electrónico, salvo que se tengan en cuenta parámetros de autenticidad electrónica que algunos de los expertos pretenden eliminar de la factura electrónica.

En todo caso, mi posición personal es que no se puede imponer un modelo que cada vez es menos seguro (el del papel) sobre otro que nace con cierto nivel de seguridad. Por el contrario, dado que las facturas en papel son fácilmente falsificables se debería imponer una exigencia de seguridad adicional (se me ocurren varias: usar papel con marcas de agua, usar papel timbrado, usar papel con marcas de trepado, por ejemplo indicando el CIF del emisor, usar papel con tintas ultravioletas,…)

Por todos estos argumentos y algunos más estoy preparando un documento que recoja la posición española a favor del mantenimento de la firma electrónica de las facturas electrónicas en la Directiva 2006/112/CE, y de la adopción internacional a corto de plazo del estándar UBL, sin perjuicio de una migración futura a CII, cuando la norma esté más madura. La idea es enviarlo a la UE en el marco de la consulta  «Consultation on the Final Report of the Expert Group on e-Invoicing».

Estoy abierto a que me envieis comentarios y sugerencias para su inclusión en el documento, pero recordad que el período de la consulta se extiende desde el 30.11.2009 hasta el  26.2.2010, por lo que tengo que enviar el documento en inglés antes del cierre del plazo. Si alguien quiere contactar conmigo para este tema, que llame al 902 365 612.